環境構築 2 (1.7.10)

1.7.10の開発講座を修正中です。このページには誤りや古い情報が含まれる可能性があります。

MODを開発するための環境を整えます。基本的にWindows 10で確認しているので、MacやLinuxでは異なる部分があります。

複数のMODを開発する時は、Forgeの手順3以降を行います。

Forge

GradleとForge Gradleプラグインのバージョンに関する問題が確認されています。詳しくはコメント欄をご覧ください。

  1. ダウンロードページからほしいバージョンの「src」を選択すると、「AdFoc.us」というページに移動します。推奨版という意味の「Recommended」を選択するとよいでしょう。
  2. 5秒待つと右上に「SKIP」というボタンが出るので、これをクリックしてダウンロードしてください。下の方の「ダウンロード」などのボタンは広告です。
  3. ダウンロードしたzipファイルを解凍してください。日本語の入っていない場所がよいでしょう。今回は例として"C:/Modding/AluminiumMod"を使用します。"C:/Modding/AluminiumMod/"に"src"フォルダや"build.gradle"などがあるようにしてください。
  4. IntelliJ IDEAを起動して「Open」から"C:/Modding/AluminiumMod"を選択し、出てきたダイアログで「OK」ボタンを押します。この時、"AluminiumMod"がGradleの緑色のマークで表示されていることを確認してください。
  5. しばらく待って画面右下に表示されている処理が終了したら、エクスプローラで"C:/Modding/AluminiumMod"を開いてウィンドウ上部のアドレスバーに「cmd」と入力し、コマンドプロンプトを開いてください。
  6. コマンドプロンプトに「gradlew setupDecompWorkspace」と入力して実行すると、自動で環境が整えられます。しばらくして「BUILD SUCCESSFUL」と出たら成功です。
  7. コマンドプロンプトに「gradlew idea」と入力して実行すると、IntelliJ IDEAに対応した環境が整えられます。しばらくして「BUILD SUCCESSFUL」と出たら成功です。
  8. コマンドプロンプトに「gradlew genIntellijRuns」と入力して実行すると、IntelliJ IDEAでテストプレイするための環境が整えられます。これも「BUILD SUCCESSFUL」と出たら成功です。
  9. IntelliJ IDEAに戻って右上の下向き三角のボタンから「Minecraft Client」を選択し、緑色の右向き三角のボタンで実行してください。Minecraftが起動すれば、成功です。

準備

  1. IntelliJ IDEAで「com.example.examplemod.ExampleMod」を開き、クラスの宣言部分にカーソルを移動させてAlt+Enterから「Suppress for class annotated by ...」を選択すると、@Modをつけたクラスに対する未使用の警告がなくなります。
  2. initメソッドの宣言部分でも同様にし、@EventHandlerを登録してください。
  3. 「Project View」で"AluminiumMod/src/main/java/"にある"com.example.examplemod"を削除してください。中にはサンプル用のMODが入っています。
  4. "com.example"が残るのでもう一度削除してください。
  5. "AluminiumMod/src/main/resources/"にある"mcmod.info"を削除してください。MODの情報を登録するファイルですが、この開発講座では使いません。
  6. "AluminiumMod/src/main/java/"を右クリックし、「New>Package」から"tutorial.aluminiummod"パッケージを作成してください。
  7. "tutorial.aluminiummod"を右クリックし、「New>Java Class」から"AluminiumMod"を作成してください。
  8. これで準備は完了です。今後は必要に応じてファイルを追加してください。

環境構築 2 (1.7.10)” への28件のフィードバック

  1. ありがとうございます!!
    Gradleのバージョンの問題ですかね?

  2. 環境構築に失敗します。

    OSはmacOS Catalina 10.15.2ですが、手持ちのWindowsでも同様のエラーが発生しました。
    エディタはIntelliJ IDEA Ultimate 2019.3.1
    forgeは1.7.10-10.13.4.1558
    javaは1.8.0_212
    解凍したフォルダのパスは/Users/(ユーザー名)/Documents/Develop/TestMod

    はじめにIntelliJにOpenから解凍したフォルダを読み込んだときに下の枠に

    Support for builds using Gradle versions older than 2.6 was removed in tooling API version 5.0. You are currently using Gradle version 2.0. You should upgrade your Gradle build to use Gradle 2.6 or later.

    Possible solution:
    - Upgrade Gradle wrapper to 2.6 version and re-import the project

    と出て、"Upgrade Gradle wrapper to 2.6 version and re-import the project"をクリックすると

    Cannot determine classpath for resource 'java/sql/SQLException.class' from location 'jrt:/java.sql/java/sql/SQLException.class'.

    The project uses Gradle 2.6 which is incompatible with IDEA running on Java 10 or newer.
    See details at https://github.com/gradle/gradle/issues/8431
    Possible solution:
    - Upgrade Gradle wrapper to 4.8.1 version and re-import the project

    "Upgrade Gradle wrapper to 4.8.1 version and re-import the project"をクリックすると

    Build file '/Users/(ユーザー名)/Documents/Develop/TestMod/build.gradle' line: 18

    A problem occurred evaluating root project 'TestMod'.

    Failed to apply plugin [id 'forge']
    You must set the Minecraft Version!
    java.lang.NullPointerException (no error message)

    とでます。
    ./gradlew setupDecompWorkspaceと打つと、

    FAILURE: Build failed with an exception.

    Where:
    Build file '/Users/(ユーザー名)/Documents/Develop/TestMod/build.gradle' line: 18
    What went wrong:
    A problem occurred evaluating root project 'TestMod'.

    Failed to apply plugin [id 'forge']
    You must set the Minecraft Version!
    java.lang.NullPointerException (no error message)

    Try:
    Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights.
    Get more help at https://help.gradle.org

    BUILD FAILED in 1s

    と表示されます。
    この状態でgradlewのバージョンを調べてみると

    Gradle 4.8.1

    Build time: 2018-06-21 07:53:06 UTC
    Revision: 0abdea078047b12df42e7750ccba34d69b516a22

    Groovy: 2.4.12
    Ant: Apache Ant(TM) version 1.9.11 compiled on March 23 2018
    JVM: 1.8.0_212 (Oracle Corporation 25.212-b10)
    OS: Mac OS X 10.15.2 x86_64

    と表示されました。
    WindowsでもMacでも、今年の1/1にはセットアップ、制作、実行できていた環境でも
    Failed to apply plugin [id 'forge']
    のエラーが発生します。

    何かのアップデートが入ったのでしょうか。よろしくお願いします。

  3. gradlew setupDecompWorkspaceと打つと、次のようなエラーが出ます。

    What went wrong:
    A problem occurred configuring root project 'ZOIguns'.

    Could not resolve all dependencies for configuration ':classpath'.
    Could not resolve org.eclipse.equinox:common:[3.2.0,4.0.0).
    Required by:
    :ZOIguns:unspecified > net.minecraftforge.gradle:ForgeGradle:1.2-SNAPSHOT > net.minecraftforge.srg2source:Srg2Source:3.2-SNAPSHOT > org.eclipse.core:jobs:3.5.300-v20130429-1813
    :ZOIguns:unspecified > net.minecraftforge.gradle:ForgeGradle:1.2-SNAPSHOT > net.minecraftforge.srg2source:Srg2Source:3.2-SNAPSHOT > org.eclipse.core:contenttype:3.4.200-v20130326-1255
    :ZOIguns:unspecified > net.minecraftforge.gradle:ForgeGradle:1.2-SNAPSHOT > net.minecraftforge.srg2source:Srg2Source:3.2-SNAPSHOT > org.eclipse.equinox:preferences:3.5.100-v20130422-1538
    Failed to list versions for org.eclipse.equinox:common.
    Unable to load Maven meta-data from http://repo1.maven.org/maven2/org/eclipse/equinox/common/maven-metadata.xml.
    Could not GET 'http://repo1.maven.org/maven2/org/eclipse/equinox/common/maven-metadata.xml'. Received status code 501 from server: HTTPS Required
    Could not resolve org.eclipse.equinox:preferences:[3.2.0,4.0.0).
    Required by:
    :ZOIguns:unspecified > net.minecraftforge.gradle:ForgeGradle:1.2-SNAPSHOT > net.minecraftforge.srg2source:Srg2Source:3.2-SNAPSHOT > org.eclipse.core:contenttype:3.4.200-v20130326-1255
    Failed to list versions for org.eclipse.equinox:preferences.
    Unable to load Maven meta-data from http://repo1.maven.org/maven2/org/eclipse/equinox/preferences/maven-metadata.xml.
    Could not GET 'http://repo1.maven.org/maven2/org/eclipse/equinox/preferences/maven-metadata.xml'. Received status code 501 from server: HTTPS Required
    Could not resolve org.eclipse.equinox:registry:[3.2.0,4.0.0).
    Required by:
    :ZOIguns:unspecified > net.minecraftforge.gradle:ForgeGradle:1.2-SNAPSHOT > net.minecraftforge.srg2source:Srg2Source:3.2-SNAPSHOT > org.eclipse.core:contenttype:3.4.200-v20130326-1255
    Failed to list versions for org.eclipse.equinox:registry.
    Unable to load Maven meta-data from http://repo1.maven.org/maven2/org/eclipse/equinox/registry/maven-metadata.xml.
    Could not GET 'http://repo1.maven.org/maven2/org/eclipse/equinox/registry/maven-metadata.xml'. Received status code 501 from server: HTTPS Required
    Could not resolve org.eclipse.core.runtime:compatibility:[3.1.0,4.0.0).
    Required by:
    :ZOIguns:unspecified > net.minecraftforge.gradle:ForgeGradle:1.2-SNAPSHOT > net.minecraftforge.srg2source:Srg2Source:3.2-SNAPSHOT > org.eclipse.core:resources:3.2.1-R32x_v20060914
    Failed to list versions for org.eclipse.core.runtime:compatibility.
    Unable to load Maven meta-data from http://repo1.maven.org/maven2/org/eclipse/core/runtime/compatibility/maven-metadata.xml.
    Could not GET 'http://repo1.maven.org/maven2/org/eclipse/core/runtime/compatibility/maven-metadata.xml'. Received status code 501 from server: HTTPS Required
    Could not resolve org.eclipse.core:expressions:[3.1.0,4.0.0).
    Required by:
    :ZOIguns:unspecified > net.minecraftforge.gradle:ForgeGradle:1.2-SNAPSHOT > net.minecraftforge.srg2source:Srg2Source:3.2-SNAPSHOT > org.eclipse.core:resources:3.2.1-R32x_v20060914
    Failed to list versions for org.eclipse.core:expressions.
    Unable to load Maven meta-data from http://repo1.maven.org/maven2/org/eclipse/core/expressions/maven-metadata.xml.
    Could not GET 'http://repo1.maven.org/maven2/org/eclipse/core/expressions/maven-metadata.xml'. Received status code 501 from server: HTTPS Required
    Could not resolve org.eclipse.core:filesystem:[1.0.0,2.0.0).
    Required by:
    :ZOIguns:unspecified > net.minecraftforge.gradle:ForgeGradle:1.2-SNAPSHOT > net.minecraftforge.srg2source:Srg2Source:3.2-SNAPSHOT > org.eclipse.core:resources:3.2.1-R32x_v20060914
    Failed to list versions for org.eclipse.core:filesystem.
    Unable to load Maven meta-data from http://repo1.maven.org/maven2/org/eclipse/core/filesystem/maven-metadata.xml.
    Could not GET 'http://repo1.maven.org/maven2/org/eclipse/core/filesystem/maven-metadata.xml'. Received status code 501 from server: HTTPS Required
    Could not resolve org.eclipse:osgi:[3.7.0,4.0.0).
    Required by:
    :ZOIguns:unspecified > net.minecraftforge.gradle:ForgeGradle:1.2-SNAPSHOT > net.minecraftforge.srg2source:Srg2Source:3.2-SNAPSHOT > org.eclipse.core:runtime:3.9.0-v20130326-1255
    Failed to list versions for org.eclipse:osgi.
    Unable to load Maven meta-data from http://repo1.maven.org/maven2/org/eclipse/osgi/maven-metadata.xml.
    Could not GET 'http://repo1.maven.org/maven2/org/eclipse/osgi/maven-metadata.xml'. Received status code 501 from server: HTTPS Required
    Could not resolve org.eclipse.equinox:common:[3.6.100,4.0.0).
    Required by:
    :ZOIguns:unspecified > net.minecraftforge.gradle:ForgeGradle:1.2-SNAPSHOT > net.minecraftforge.srg2source:Srg2Source:3.2-SNAPSHOT > org.eclipse.core:runtime:3.9.0-v20130326-1255
    Failed to list versions for org.eclipse.equinox:common.
    Unable to load Maven meta-data from http://repo1.maven.org/maven2/org/eclipse/equinox/common/maven-metadata.xml.
    Could not GET 'http://repo1.maven.org/maven2/org/eclipse/equinox/common/maven-metadata.xml'. Received status code 501 from server: HTTPS Required
    Could not resolve org.eclipse.core:jobs:[3.2.0,4.0.0).
    Required by:
    :ZOIguns:unspecified > net.minecraftforge.gradle:ForgeGradle:1.2-SNAPSHOT > net.minecraftforge.srg2source:Srg2Source:3.2-SNAPSHOT > org.eclipse.core:runtime:3.9.0-v20130326-1255
    Failed to list versions for org.eclipse.core:jobs.
    Unable to load Maven meta-data from http://repo1.maven.org/maven2/org/eclipse/core/jobs/maven-metadata.xml.
    Could not GET 'http://repo1.maven.org/maven2/org/eclipse/core/jobs/maven-metadata.xml'. Received status code 501 from server: HTTPS Required
    Could not resolve org.eclipse.equinox:registry:[3.4.0,4.0.0).
    Required by:
    :ZOIguns:unspecified > net.minecraftforge.gradle:ForgeGradle:1.2-SNAPSHOT > net.minecraftforge.srg2source:Srg2Source:3.2-SNAPSHOT > org.eclipse.core:runtime:3.9.0-v20130326-1255
    Failed to list versions for org.eclipse.equinox:registry.
    Unable to load Maven meta-data from http://repo1.maven.org/maven2/org/eclipse/equinox/registry/maven-metadata.xml.
    Could not GET 'http://repo1.maven.org/maven2/org/eclipse/equinox/registry/maven-metadata.xml'. Received status code 501 from server: HTTPS Required
    Could not resolve org.eclipse.equinox:preferences:[3.4.0,4.0.0).
    Required by:
    :ZOIguns:unspecified > net.minecraftforge.gradle:ForgeGradle:1.2-SNAPSHOT > net.minecraftforge.srg2source:Srg2Source:3.2-SNAPSHOT > org.eclipse.core:runtime:3.9.0-v20130326-1255
    Failed to list versions for org.eclipse.equinox:preferences.
    Unable to load Maven meta-data from http://repo1.maven.org/maven2/org/eclipse/equinox/preferences/maven-metadata.xml.
    Could not GET 'http://repo1.maven.org/maven2/org/eclipse/equinox/preferences/maven-metadata.xml'. Received status code 501 from server: HTTPS Required
    Could not resolve org.eclipse.core:contenttype:[3.3.0,4.0.0).
    Required by:
    :ZOIguns:unspecified > net.minecraftforge.gradle:ForgeGradle:1.2-SNAPSHOT > net.minecraftforge.srg2source:Srg2Source:3.2-SNAPSHOT > org.eclipse.core:runtime:3.9.0-v20130326-1255
    Failed to list versions for org.eclipse.core:contenttype.
    Unable to load Maven meta-data from http://repo1.maven.org/maven2/org/eclipse/core/contenttype/maven-metadata.xml.
    Could not GET 'http://repo1.maven.org/maven2/org/eclipse/core/contenttype/maven-metadata.xml'. Received status code 501 from server: HTTPS Required
    Could not resolve org.eclipse.equinox:app:[1.0.0,2.0.0).
    Required by:
    :ZOIguns:unspecified > net.minecraftforge.gradle:ForgeGradle:1.2-SNAPSHOT > net.minecraftforge.srg2source:Srg2Source:3.2-SNAPSHOT > org.eclipse.core:runtime:3.9.0-v20130326-1255
    Failed to list versions for org.eclipse.equinox:app.
    Unable to load Maven meta-data from http://repo1.maven.org/maven2/org/eclipse/equinox/app/maven-metadata.xml.
    Could not GET 'http://repo1.maven.org/maven2/org/eclipse/equinox/app/maven-metadata.xml'. Received status code 501 from server: HTTPS Required

    Try:
    Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.

    BUILD FAILED

    Total time: 26.14 secs

  4. こちらでも、1.7.10の開発環境を構築できないことを確認しました。GradleのバージョンがIntelliJ IDEAのサポート対象外であることが、最初のエラーの原因だと思われます。Forgeのサポートは最新版と1.14.4に移行したため、今後、この問題が修正される可能性は低いでしょう。

    1. ありがとうございます。
      1.7.10での開発は諦めたほうが良いということですか?

      1. 先程承認したコメントにて解決策をご指摘いただきました。私の確認不足により、ご迷惑をおかけしました。

  5. 自分も同じ問題に直面したのですが、調べてみたところ、Maven Centralの完全Https化により、1.7.10のSrcだとアクセスできない(httpでアクセスしているため)ようになってしまった(2020/1/15より)ようです。
    解決策としては、有志の方が作ってくださったForge Gradle 1.2のGradle4.5以降対応版があるのでそれを用いれば依存解決ができない問題(Could not resolve all dependencies for configuration ‘:classpath:’)は治ります。
    配布リンクはhttps://github.com/anatawa12/ForgeGradleになります。
    もっと詳しいこの問題についての記事はhttp://www.qrunch.net/@toliner/entries/XsEydENmoDjW2qY7?ref=qrunchになります。

    1. 私の調査不足でした。情報の提供ありがとうございます。

  6. 有志の方によるForgeGradle1.2対応Gradle4.5以降版でなくとも
    Gradle2.xのマイナーアップデートである2.1でhttpsリクエストに対応するようになったので
    Gradleが古い環境でもいいという方はこちらを使うといいと思います

  7. IntelliJ使ってるならIntelliJのプラグインでMOD開発とかプラグイン開発の
    補助ツールがあるので、それ使えばええで

    1. それってMinecraftDevelopmentですよね?
      だったら1.12までしか対応してなかった気が

  8. FAILURE: Build failed with an exception.

    What went wrong:
    Could not determine java version from '13.0.2'.
    Try:
    Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights.
    Get more help at https://help.gradle.org
    となっているのですが、JDKのバージョンを下げればいいんですかね?
    動作確認してあるJDKなどあったら教えていただけると幸いです。

    1. 環境構築 1にJDK 8が必要と書いてあります。

コメントはこちらです。(スパム対策の為コメントは手動承認になっています。未承認のコメントは表示されないので連投はお控え下さい。)

このサイトはスパムを低減するために Akismet を使っています。コメントデータの処理方法の詳細はこちらをご覧ください